This repository has been archived on 2024-10-19. You can view files and clone it, but cannot push or open issues or pull requests.
server-nixos-config/jimbo.nix

21 lines
431 B
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{pkgs, ...}: let
secrets = import ./secrets.nix;
in {
# Define a user account. Don't forget to set a password with passwd.
users.users.jimbo = {
description = "Jimbo";
isNormalUser = true;
openssh.authorizedKeys.keys = secrets.jimKeys;
extraGroups = [
"networkmanager"
"wheel"
"nginx"
"nfsShare"
];
shell = pkgs.zsh;
};
# Enable ZSH
programs.zsh.enable = true;
}