NixOS-Config/modules/system/programs/sway/default.nix

14 lines
296 B
Nix

{ config, pkgs, ... }:
{
imports = [ ./greetd ];
programs.sway = {
enable = config.system.desktop.enable;
package = pkgs.unstable.sway;
extraPackages = with pkgs; [ swaylock ];
};
services.dbus.enable = config.system.desktop.enable;
security.pam.services.swaylock = {};
}